Ephinea PSO BB on Steam Deck (Official Thread)


Staff member
This thread will serve as technical support and instructions on how to get the best possible experience on the Steam Deck.

If you require technical support for installation on the Steam Deck, you must post in this thread for a response - technical support will not be provided through Discord as I do not constantly monitor Discord, and forums also help other users who may be having the same issue.

Note that if you are having issues, please right click PSO BB in Lutris and then show logs, and please post the result. This will help figure out what is wrong.


Prerequisites: Lutris must be installed from the Discover software centre.

All of this will be done in desktop mode. This will install the game with the base lua addon plugin.
  1. Open Lutris, click the + icon in the top left, click Search the Lutris website for installers, search for Phantasy Star Online: Blue Burst, then click Install on the option named Ephinea plus addon plugin.
  2. Click Install, choose your installation directory, and then Install again. Let the installer finish.
  3. (Optional, recommended) After installing the game, right-click the game in Lutris and click Create Steam shortcut to add it to Steam for gaming mode.
  4. When you open the game for the first time, you may be asked to install Mono and Gecko, click Install, do not refuse.
If you get an error saying you don't have eSync, please follow the instructions in this post:
Ephinea PSO BB is now installed on the Steam Deck, and can be played without any issues. The EphineaPSO folder will be located in $GAMEDIR/drive_c/, where $GAMEDIR is the location you chose to install the game in Lutris. By default, this is /home/deck/Games/phantasy-star-online-blue-burst.

The pre-installed plugin is only the base plugin, and no addons are included, as this is up to user preference. To find addons to install, please see this thread.

Tips and Tricks

Note that this section is for tips and tricks for play-ability of the game. Things like controller profiles or recommended game settings are not the scope of this guide, as each user will have their own preferences. For this sort of advice, please leave a reply below.

If you have anything you feel will be useful to know in this section, please also leave a reply.
  • Play in windowed modewith resolution set to 1280x800.
    • In desktop mode, make sure that Alt+Enter is enabled. This will allow you to use the keyboard when necessary by switching between fullscreen/windowed on the fly. You will need Alt/Enter bound somewhere on the gamepad.
    • In gaming mode, this gives the game the highest level of compatibility with the mouse - this is important if playing with the lua addons. Gaming mode will still render the game fullscreen.
  • In certain scenarios, space, enter, and backspace are not registered by the game when typed with the on-screen keyboard. Due to this, it is necessary to bound these buttons onto the gamepad, as the game will recognise them from there. This is mandatory for things like logging in or making parties at the lobby counter.
Hopefully this guide has been useful to you, if you're having any issues, please feel free to leave a reply and I'll get back to you as soon as possible.


Error Code: 256 when installing​

  • There are currently issues when installing to external media (such as an SD Card) in Lutris. Install on the internal drive first, then move the phantasy-star-online-blue-burst folder, then right click the game and configure Lutris to point at the new location.
  • Lutris cannot always overwrite old files, so you may need to delete any old phantasy-star-onine-blue-burst folders if applicable.

Game is extremely dark​

  • An incorrect Direct3D API is being used. Change your Direct3D API to Direct3D 8.

Game crashes randomly without any error message​

  • This is most likely an issue with Wine, the wrapper that allows the game to be played on Linux (note that Proton is the same thing). Follow the steps below to change the Wine runner.
    • Download ProtonUp-Qt from the Discover software centre.
    • Open ProtonUp-Qt, choose Lutris Flatpak in the drop down box, then Add version. It should already be on the latest Wine-GE version, click Install and allow it to install.
    • In Lutris, right-click on PSO BB, click on Configure, click on Runner options, then change the Wine version to the Lutris-GE-Proton version you just installed, then click Save.
  • You should now be able to play the game without issues, although the first launch may have an error due to changing the Wine version.

Unable to control in Desktop mode​

  • Hold the menu button (the 3 line button near the right analog stick) until a pop-up appears in the bottom right changing the controller to gamepad mode. The default setting is designed for keyboard presses on the buttons for browsing.
Last edited:
It seems the most recent flatpak version of Lutris (0.5.12) has changed how it handles some things, which means it should be able to browse and execute a YAML script on the local filesystem. I have to leave at this very moment, but I'll look at this today or tomorrow, and if it works fine I'll add updated installers to the OP which will simplify the process a lot more.
Update: Lutris 0.5.12 also seems to have fixed any issues with creating Steam shortcuts in Lutris, so that entire branch has been simplified. Everything will now be handled within Lutris - nothing needs to be configured inside Steam (other than things like personal controller setups and the like).
Update: I've simplified the instructions even further, and provided an install script that will just install the Lua addon plugin for you. This doesn't include any addons or configuration, as that's up to the user.

If, for some reason, you wish to disable the addons entirely, just open the configure menu in Lutris, go to runner options, then delete the entry under DLL overrides. Alternatively, you can delete the dinput8.dll file.
Hi! I'm having troubles getting this to run. I remember installing Lutris on the first day I had my deck and messed around a bit (iirc, I disabled read-only mode to get the wine dependencies?) for FFXIV, but I couldnt get it to work.

Either way, I installed Wine from Discover as well and booted up Lutris, but was greeted with this error:
"Missing vulkan libraries: Lutris was unable to detect Vulkan support for the i386 architecture. This will prevent many games and programs from working. To install it, please use the following guide: https://github.com/lutris/docs/blob/master/InstallingDrivers.md "

If I click okay past that, Lutris still launches, and I can try to install from script.: however it would warn me that "Wine is not installed", and, if I tried to forge forward, would fail partway thru the Ephinea installation.

That was yesterday. This morning, the "install from script" option no longer works, getting clicked as normal but then not displaying any sort of menu with which to select the yaml/json file.

I tried uninstalling and then reinstalling both Lutris and Wine, in case this would fix that. It did actually fix the "Missing vulkan libraries" error... but not this new one.

I'm not entirely sure what to do, but I'm currently searching for answers.
Update: I ended up getting it working! I used the Ephinea thing off the Lutris website instead of the script... It's non ideal, as I imagine ti will have some issues with game mode... but as I'm using my Deck as my primary desktop computer with a M+KB+Monitor plugged in, it probably will work for me.
To me these sound like they're relating to conflicting files from a regular install of Lutris and one from the Discover store. If you followed a guide to get all the wine dependencies from the terminal, you will have also installed the non-flatpak version of Lutris (which is superior, but SteamOS makes it very, very annoying to use anything outside of flatpak due to how the OS is imaged on updates).

Any steam client or OS updates after this would have deleted and written over certain files, causing yet more issues.

If I had to guess, the issue would have been that you had certain configuration files from the prior version of Lutris, which you should have removed with:
sudo pacman -R lutris
Having Wine installed wouldn't have been an issue though, as SteamOS ships with the stable 7.0 version of Wine (since this is what Proton is based on), but i'm guessing the installation of extra Wine dependencies caused issues when the flatpak version was searching.

The file picker not appearing when trying to install from the script is also yet another issue with flatpak not being able to access the executable it needs, but a proper restart of the system should resolve this.

In short: SteamOS sucks. Ironically it is one of the worse Linux distributions for gaming as its immutable filesystem and dependency of flatpak can cause all sorts of issues. It is the Steam client that makes people think it is great, but this is independent from the OS.
I ran into an issue as i got the game running through the script an everything but everytime i bring up the onscreen keyboard to login it closes the login entry box making it impossible to log in with the on screen board this issue mostly happens because of the button combo needed to activate the keyboard uses x which makes the menu close

Also: are there any reccommended community contoller layouts or just in general good bindings i can use specially cus i use the numpad hot keys alot
Last edited:
Are you trying to press the buttons at the same time? Hold the Steam key first, then press X, it will not cancel the menu.
Are you trying to press the buttons at the same time? Hold the Steam key first, then press X, it will not cancel the menu.
Holy shit it was that simple,thanks for the help. Now all i gotta do i find a control layout that isnt missing functions or has its functions just spread everywhere lol
It's like that for most modifier keys (Ctrl, Alt, Win/Super, etc), they won't act until they are released, so you can usually hold the modifier key first, then press the actual combo button you need.

As for controller profiles, it seems there's a lot of community profiles, although I dunno how robust they are. You could try mine if you wanted as a base: https://psp2i.wiki/files/ephinea pso_0.vdf (right-click save as)

I don't provide one here in the main post as everyone has their own preferences. To use it, put the file in /home/deck/.steam/steam/controller_base/templates, then load the template from... somewhere, it is called "Ephinea PSO". I would guess the generic templates menu.

My profile works mostly as you'd expect, but here's my own personal changes:

F12: R2
0: L2
9: R3
8: L3
7: Menu button (the button near the right-stick)
6: Options button (the button near the left-stick)
5: RS-Up
4: RS-Right
3: RS-Down
2: RS-Left
1: L4
Space: R4
Backspace: L5
Enter: R5

Beyond this I don't do anything special, but some people set radial menus for chat shortcuts, use mouse click for certain combinations, and so on. As it's all up to preference, there is no perfect controller layout.

Best thing to do is actually figure out what you want. All you really *need* to consider is the 1-0 bar and space/backspace/enter, then from there it's up to preference.
I had to uninstall my old version of PSO Ephinea and reinstall following the guide here, and it works - and I was able to log in, so all my progress remains!

However, the game just keeps crashing on my Steam Deck and I have no idea why. I can't even get to Forest 2 on Ultimate without it just crashing to SteamOS. Is there some sort of workaround or mod or something I should install to make it more stable? It's pretty frustrating...!
Kind of hard to help with this information, I'm going to need a bit more:

- Where exactly is it crashing? A specific area? Certain enemy spawn? When doing a certain action? Etc.
- Have you installed any sort of extras such as texture skins or model replacements?
- It's possible that Direct3D 11 doesn't work well enough - it may be worth trying out Direct3D 8.
- What build of SteamOS are you on? Note that SteamOS is not gaming mode, SteamOS is the operating system. It's either Stable, Beta or Future, I believe. I recommend using Stable always - PC gamers have a bad habit of recommending unstable builds because "it fixed my niche issue/use case."
- What kind of crash is it? Disconnection? Error message? Just exits back to Steam?

I'm assuming here that you are playing in the gaming mode steam client.
It crashes seemingly randomly - I've had it crash in hallways with no enemies, in the room with the teleporter to Forest 2, the first room of Forest 1, etc. No extras installed, not even high res HUD. I'll have to look into Direct3D 8, since I believe I'm using 11. And yes, I'm in gaming mode, stable build. It just exits back to Steam, no error message or whatever.
Can you try playing in desktop mode temporarily (boot up Lutris, click PSO, click play at the bottom)? See if you get the same issues there, and if you do we can take a look at the Lutris logs to find out why the executable is closing randomly. (Right click game -> Show logs after a crash, it should have some information)

You may need to hold the menu button (the 3 line button next to the right analog stick) to get the gamepad working in game. Play in windowed mode since you'll need to do so to use keyboard if you need it.
I can't get any controls to work in Desktop mode. My character can only seem to sit in a chair no matter which button I push, so I can't get to the counter to start a game lol
Just tried Direct3D 8 in Game Mode, crashed in Forest 1 when shooting boxes several rooms into the level.
I can't get any controls to work in Desktop mode. My character can only seem to sit in a chair no matter which button I push, so I can't get to the counter to start a game lol
Like I said, hold the menu button to change it to gamepad mode in desktop mode. That's the button next to the right-analog stick.