Windows 10 Strikes Again? (Client won't launch)

Zoogy Long

Sleeping Dragon
UPDATE #4: Less than a day before I bricked it again.

The game was working beautifully but ever since the CrU update I drop connection on wired Ethernet every few minutes for a split second (not even long enough to get a triangle error), that would cause kick from the server.

Alt tabbed out (in borderless full screen, not classic) and while working on connection issues got an error about Direct3d (or DirectDraw) not being able to render and the application would close. Figured it was fine, and was because I was hogging resources and hopping around different programs.

Now the old behavior has returned and the game won't start. Shite. The DXDIAG dump from the hardware log looks good. :(

Whatever the issue is it's the same that doesn't allow Resident Evil Revelations 2 to start (it also miraculously started working after a previous update).

Seems like it might be simpler than I am aware of, I feel like I just need to reset something in the Nvidia options after one of these failures. Not sure what though. Driving me absolutely nuts.

------------------
UPDATE #3: ALL OF A SUDDEN IT WORKS TODAY!?!?
I'm not going to question it....
Must have been some odd specific setting in the Nvidia options, or deprecation issues. Although, I swear I tried it after the driver update this morning/last night.
----------------
UPDATE #2: I spoke too soon, that was just the usual from having a bad res config while experimenting.

Tried a fresh manual install (registry is fine) without updating just to see if the client launches at all. Still no luck.

So unless something got rolled into the manual installation package recently it's definitely a graphics driver or OS problem. *sigh*
---------------
UPDATE #1: Update Card drivers! Still no luck, but instead of the "PSOBB.EXE HAS STOPPED WORKING" standard crash with no error logs, it just terminates! - but now with an error log about D3D not initializing (I figured as much but...)! Progress!

Error : Can't find DisplayMode
Error : Can't use format [D3DFMT_X8R8G8B8]

Error : Can't find DisplayMode
Error : Can't use format [D3DFMT_A8R8G8B8]
----------------
Soooo.... after the last update PSOBB no longer launches in Windows 10.

Went through the usual gamut of settings, and tried a fresh install including:

  • DEP Settings
  • Making sure a recent Win10 update didn't delete any dependent features (afflicted many FFXIV users)
  • Every resolution available
  • Compatibility Modes / Administrator (was already on, experimented with more modes)
  • Fresh install (With and without cleaning up registry first)
  • All AV Exclusions set (have been, but double checked)
  • Different Drive/Install locations (just in case)
  • Priority Settings
Blagh. It's driving me batty. Not long ago was punching Rappies in the face in glorious 1920 Borderless Full Screen. I seem to be the only one affected (or at least the first to mention it, aside from that China based post) so far.

I'm an old hand with PC's as well. Near as I can tell nothing is missing from Windows processes, read/write permissions, or any other goofy OS or Power issues that could cause a conflict.

The behavior of the PSOBB client is that it succesfully launches the window shell for 5-30 seconds (seems to be struggling to load. I've monitored the resources to see the CPU/Mem usage and to watch for issues with any potential dependencies) before hard crashing without loading any content (but the custom mouse icon). Length seems to be based on whether it's in compatibility mode or not. Lasts the longest in XP:SP2

No error logs are generated.

Going a wee bit crazy over it. I feel like all my repair classes were wasted AND I can't punch Rappies anymore.

Well, not on a smooth computer anyway, my crummy laptop still runs the game as well as it ever did.

The only thing I can think of is that something in the update may not be jiving with something with the video card drivers?

Driver :nvldumd.dll
Description:NVIDIA GeForce GTX 960
VendorID :000010DE
DeviceID :00001401
SubSysID :32021462
Revision :000000A1

DEVICE :HAL-HARD
 
Last edited:

Zoogy Long

Sleeping Dragon
Anyone else playing on an up to date GTX 960?

Tried again today from the main computer after new updates and still same issues. I fear it's just no longer supported. T.T
 

Zoogy Long

Sleeping Dragon
Thanks for the confirmation. It must be Windows 10 then? Not sure what though, permissions look good. Registry looks good. No Defender issues, or DEP problems. It just stopped working after the June 18th update.

Everything looks good on the PSOBB side too though. Very frustrating :(
 

Soly

Member
Maybe you can try the opposite, remove pso from DEP (someone was having issues and it was because the game was on DEP).
It sounds weird but ¯\_ツ_/¯
 

Zoogy Long

Sleeping Dragon
No luck sadly, and Creators Update isn't helping any.... Guess it'll be laptop time for a while still.

Interesting to note, I think all DX9c games on this system are all kaput, despite the latest drivers and DXDIAG seeming to show support. Resident Evil Revelations 2 fatal errors due to not reading Dinput. Weird.
 

Jyuki

Prima Undine
I'm on the latest Win10 update and using a 1050ti, everything is working correctly.

Have you tried to :
  • Use a restore point before the PSOBB update happened ? If one is available, of course.
  • Completely remove your graphic drivers (Uninstall from Nvidia software → Download DDU and use it in safe mode http://www.guru3d.com/files-details/display-driver-uninstaller-download.html) and install the most recent ones ?
  • Try another Graphic Card ? Yours can be faulty and generate this error.
  • Try another Windows install ? (on another drive or even a Memory stick if it's 32gb+)
 
Last edited:

tofuman

Administrator
Staff member
If you have the creators update try disabling the GameDVR (Start -> Xboxapp -> Settings -> GameDVR -> turn off recording game clips and screenshots).

And try disabling game mode
 
Top