Mag window F4


So ever since the x2 event started, i can no longer press F4 to open mag window to quick feed my mag. Doing this results in the game crashing.
This happens during ragol runs and just being on pioneer.
I can open mag window trough the regular HOME/MAG and feed it with no problem, but not just pressing F4 for the MAG window.
Please be adviced, dont post "did you press alt+F4" as this isnt the case. :D
Most likely this is a problem on my end, but would appreciate help from someone who has maybe experienced something similar before and has fixed it?

All i get is this:

And clicking "Debug" just opens Visual Studio 2015 saying "an error occurred [1024]" or something similar.
Even if you press Alt + F4, the game just doesn't listen to that. It won't close (unless is the DLL closing it, that's what I do :p )

Since you have visual studio, when you debug the crash, what does visual studio say the crash is, error code and address?
Since you have visual studio, when you debug the crash, what does visual studio say the crash is, error code and address?
Since there is the x2 event ive avoided to use F4 to quickfeed my mag, but i will try and reproduce this crash and see what the debug says. ill update this post when i have more info.


So, i did some testing, and this is very odd.
I have 4 character created, but use only slot 01 and 02.
While using my RAcast on slot 02 i can feed my mag, play normally, for over 3 hours without any problems.
But i switch to my FOnewm on slot 01 and one press on F4 to open mag window and it instantly crashes the game.

Just to double check, i went back to my RAcast, logged on, created a game, pressed F4, no problem what so ever, and back to my FO directly after, it just crashes my game pressing F4.

A bit more detailed error window,

Here is the debug output info.
** the debug output window had more information, and i can send it as a .txt file if required due to sensitive system info? **
Last edited:
Well, im not sure what to do, this is a very odd bug. This only affects my character in character slot 01, and as often as you accidentally trigger a PB because of how used you are to Ctrl+arrow to use a skill, this happens to me when feeding mag, im used to F4/Give Item/F4.
This worked with no problem at all until 2 days ago. :/
This kind of stuff happens because of faulty skin files. I would theorise that whatever mag your FOnewm has is throwing up a faulty logo in the mag menu.

I highly recommend making a fresh install and see if the game works fine then.
Im not using any kind of item skins. However, im using the Echelons HUD pack.
But seems it is affecting the mag Kumara that im currently using with the above mentioned HUD pack.
Last edited:
While that may be the case, it doesn't mean that a file hasn't corrupted somewhere in your data folder.

Like I said, fresh installation, problems will most likely be gone.
Did you use the same mag in all characters?
If you did, then Matt's suggestion should help, maybe someone could upload the file ItemKTep4.afs, and you could compare it's (md5) hash to see if it's different, you could probably avoid reinstalling everything and just update this file.

As for the debug stuff...
The image you uploaded doesn't really help (me), when I debug a crash in the game, this is what I get right after opening VS
You see the "at 0xnnnnnnnn", that's pretty much what I was asking for, the address where the exception occurred.

Once you are debugging the game, use the menu Debug > Windows > Call Stack (or you can use Ctrl + Alt + C)
Take a screenshot of the most recent lines in this window, this is even better than that single message.
Last edited:
Well, now ive tested everything just to verify what is causing this problem.

Before a complete re-install i did:
- Shared the mag with all of my characters
- Tested to equip a non Kumara mag on all characters
- Tested to equip and pressing F4 and menu path for mag window

- Each character was equipped with a non Kumara and there was no problem at all.
- Each character equipped with the mag Kumara crashed while opening the mag
window with F4 and the normal menu path HOME/ITEMS/MAG/

Since i didnt want to wait for someone to share their file original; ItemKTep4.afs i went ahead
and just did a clean re install of Ephinea PSOBB and backed up the freshly created ItemKTep4.afs.
Then i installed the HUD skin; PSOBB_HUD_fullhd_echelon and did a CheckSum md5 on both files:

Original: ItemKTep4.afs - f84e79c70a97a2eb93977ffb93581574
Modded: ItemKTep4.afs - d7e48071cf9a18cca991eb7371aaefa3

(Now i assume the modded file has to have its hash number different, as thats how the algorithm works,
you modify a copy and it gets a new md5 hash)

PSOBB_HUD_fullhd_echelon.rar comes with the file ItemKTep4.afs, which you can skip copying to data folder!
This will avoid client crash when accessing MAG window while using a Kumara mag (and poossibly other mags too)

Thx for the help mr Matt, Soly
  • Like
Reactions: Mad
Ok, I thought the file was still the original...
Since the ItemKT is only untekked weapon images and mag images for the menu, I don't think it needs to be modded but ¯\_ツ_/¯.
Might want to inform @Echelon about it, even though he has not been online since January, at least here.