Sudden PS4 Controller Issues

Discussion in 'Technical Support' started by Ant, May 23, 2020.

Tags:
  1. Ant

    Ant Member

    Hi All,

    I recently starting playing on Ephinea and have been using the PS4 controller for a while (about 10+ hours). No setup was needed, I just plugged the controller in and everything worked. I just logged in tonight but the controller is doing something strange. It allows one "confirmation" button to be pressed and then the controller becomes unresponsive except for the equivalent button for "Tab".

    So the controller is connected and I tested all buttons are functioning outside of PSO. The controller also works initially for one or two buttons at the character select screen but then becomes unresponsive. Another odd piece of information, the "Confirm" and "Back" buttons work at the very start of the game. Has anyone had this happen before or have any ideas on how to fix this?

    To give a little more detail, I just played a session of FF7:Remake with the same controller. I thought maybe the controller was picking up a connection from the PS4 so I've completely disconnected that. Whatever is happening seems to have started after playing on the PS4 then going back to the PC.
     
  2. Ant

    Ant Member

    Quick update. Have tried restarts, reinstalling drivers, resetting the Ps4 controller and trying to get the PS4 device to read as a "Controller" rather than an "Audio Device". Can anyone that uses a PS4 controller confirm in the "Bluetooth & other devices" screen that the controller is able to work when read as an "Audio" device?

    Additionally, I found this other topic that works very similar to how mine is. (Although I can't move the sparkle around at the loading screen). https://www.pioneer2.net/community/threads/controller-not-working.17756/
    It seems like the controller was being read as a Player 2 controller in the OP's case. I tried the solution mentioned there with disabling the audio driver for the controller but still no luck.

    Going to get some sleep and keep trying tomorrow.
     
  3. staphen

    staphen Member

    Guildcard:
    42013252
    It should be easy to check whether you have another device hooked up to your computer that acts as a controller input. Just type Win+R to open the Run prompt, enter joy.cpl, and press Enter. That should give you your list of controllers as well as the likely order in which they appear to the game. If you do have multiple controllers listed, your best bet would be to disable controllers that you're not using through the Device Manager. If you're unable to do that, you can also try devreorder.

    https://github.com/briankendall/devreorder
     
  4. Shichimiya

    Shichimiya Member

    Location:
    Canada
    Guildcard:
    42000374
    Oh I remember having something like this happen to me before too! It was actually one of the chat settings I had set. I don't recall how I fixed it... I think it was just something I pressed on the keyboard?
     
  5. Ant

    Ant Member

    Just wanted to update that using devreorder worked. For anyone else that has this problem, plugging in the PS4 controller was actually setting up two devices (viewed with devreorder's DeviceLister.exe):
    6 axis 14 button device with hat switch
    Wireless Controller

    The Wireless Controller would show up in the Game Controllers on the PC but the 6 axis input was taking precedence in game. Using devreorder, I was able to specify Wireless Controller as the correct "Player One" controller.

    Thanks so much for the help!
     

Share This Page