FPS seems lower than it should on older laptop.

Discussion in 'Technical Support' started by Snerpydoodle, Feb 9, 2020.

  1. Snerpydoodle

    Snerpydoodle Member

    Hello, I have been fiddling with this since installing the game last night, and Im at the point where I feel like there might be some sort of other issue dragging down performance.

    The laptop im using is by no means special but I feel like It should be able to play the game at a steady higher framerate at all minimum settings except 1 notch up on draw distance and not low res textures, low resource mode, no v sync, and 1024 x 768 resolution. It has gotten better as I reduced things down from my initial setup but it still nowhere near where it should be. Id say it averages low 20s, but it varies widely depending on say which direction im looking in a room, even if I keep the same amount of enemies on screen. I do randomly get quick bursts of it seems over 60 fps out of nowhere though. I went back 7 or 8 pages and tried what I could find but nothing much seems to have helped really. Im hoping there may be some way of improving it, I tried updated my drivers and installing the control software but it didnt seem to like my system and when I tried to force the driver install windows said they were already up to date.

    My actual kinda ok laptop has a broken screen and ive been too broke to fix it and getting by with this spare computer. I ran run SMT:Imagine with a playable framerate overall on normal settings and I feel like this game cant be much more demanding than that. If I run the game with task manager open the game never seems to use more than say 50 maybe 60% processor and not much ram, it can be chugging at sub 20 fps but only using 40% processor

    AMD E1 6060 1.35 ghz
    AMD Radeon R2 Graphics integrated
    2 gb of ram

    the hd is pretty terrible on this laptop and gets overwhelmed easy but HD activity is basically non existent when playing it seems. I remember I played with similar or maybe even slightly better performance on my old pentium 3 with a tnt 2 when the game was in beta so I would think I would be able to get better performance than that computer and am thinking it must be some sort of weird problem if the game is chugging but not using all my computers resources.
     
  2. Jyuki

    Jyuki Prima Undine

    Location:
    Aqua
    Guildcard:
    42008882
    Have you tried the "Auto Frame Skip" option ? It skip frames, when needed, to keep a smooth gameplay. Theoretically.

    [​IMG]
     
    Eistee likes this.
  3. Snerpydoodle

    Snerpydoodle Member

    Forgot to mention I tried that one. It seemed to make a difference but not really a huge one in either direction. I even tried forcing a frameskip of 1 but it just seemed to make the game even choppier.

    Also just noticed, I dont think my fog is displaying at all, no matter what setting I choose. I seem to remember the game having fog when i played in the past but here I can never seem to see it no matter what settings, could this be related? I can always see the full landscape even sometimes through doors to stuff that isnt being drawn yet.
     
    Last edited: Feb 10, 2020
    Jyuki likes this.
  4. Nikki

    Nikki meh...

    A few laptop onboards really really hate old games like PSO, try disabling advanced effect that helps sometimes. If not that, make sure its using the GPU to display the game and not all on CPU. Meddling with core affinity in task manager can sometimes help too.
     
    Jyuki likes this.
  5. Snerpydoodle

    Snerpydoodle Member

    Thanks! I have turned that off today i actually tried running the game on pure minimum settings at 640x480 and the framerate was still pretty choppy and up and down and it sometimes drags in areas that dont have any reason too. At the same time i can be looking at 20 players in the lobby and have it be around say 10 fps but its only using 20 percent cpu.

    I messed with core affinity a bit last night without noticing much of anything, how would I tell if the gpu is doing anything? Maybe that has something to do with why there is no distance fog as i seem to remember the game having it but maybe my memory is bad.
     
  6. Nikki

    Nikki meh...

    I haven't had a AMD system in some years, but if its anything like Nvidia thats a setting you could check in your control panel, to make sure its using the GPU.
     
  7. DesertWolf93

    DesertWolf93 Member

    Guildcard:
    42053158
    I'm curious... I'm running a similar platform an HP 2000 laptop amd and have had the same chugging issue with no fix improving it very much. Are you running Windows 10? Is that the original OS for the computer? And do you have any compatibility mode settings enabled on your .exe files?
     
  8. Snerpydoodle

    Snerpydoodle Member

    I found a download for drivers and a radeon conttol utility on the amd site. It seemed to improve performance a bit. I made it force anistropic filtering in a hopes of forcing the gpu to be engaged if it wasnt. Task manager resources still show up very low.

    I am on windows 8 it is the original os ive tried xp sp2 compatability mode but it didnt seem to make much if a difference.
     
  9. Terra

    Terra Member

    Location:
    Canadaland
    Guildcard:
    42032645
    By chance are you using the monster or item reader lua plugins? CPUs with weaker single core will struggle with them on. If this is the case, disable monster reader/set the item reader to a slower update rate (~1-2 seconds).
     
  10. Snerpydoodle

    Snerpydoodle Member

    I dont think I am unless they are enabled by default, but thank you!

    My processor is dual core but not a very good one hehe.

    Playing with the new drivers things are better for sure and nothing so far unplayable but in certain areas seemingly at random ill get bursts of super high framerates. I seem to remember a room in caves 2 doing it and also a few times fighting the ruins boss.
     

Share This Page