Quest desync bug

Ryan

Heavenly/Luck
Staff member
I started to play 1-2 on Very Hard with my good old buddy anime and this bizarre thing happened... Some doors weren't loaded for me, there were items on the ground (probably from when anime was in F1 killing stuff) and when anime killed a Booma I couldn't see, he got disconnected immediately. Seems like the server didn't load the quest properly, and sent him the properly loaded quest file and not me...? I dunno much about how PSO works, so I'm kind of clueless... I attached some pictures of the lack of doors, it was really bizarre. He saw me teleport through them when I walked where they should be.
 

Attachments

  • pso1440626270.png
    pso1440626270.png
    705.1 KB · Views: 72
  • pso1440626288.png
    pso1440626288.png
    665.7 KB · Views: 82

Sodaboy

Administrator
Staff member
I really didn't know what to say about this, I know it happened one time before, but I don't know what causes it. Might be bad data between the clients... If it happens every time with the quest, I'd say something's wrong, but typically the server sends both of you the same quest data... exception is when someone joins the game afterward and then the host of the game will send their information about the quest.

If you ever see it happen at the start of a quest again, I'd advise /lobby !
 

Ryan

Heavenly/Luck
Staff member
It doesn't happen every time, I've played 1-2 at least five times now and this is the first time it's happened.
 

Mylandra

Member
That's the first time I've seen this happen to someone.
Can anyone confirm if this ever happened on other servers or only on this one?
 
Top