Problems with 360 controller

I started an account on this server about a month back, and was playing using a 360 controller without any issues. At the time I was using Windows 7, but recently upgraded to Window 10. I reinstalled the Ephinea client fresh on Win10, but the controller doesn't seem to work with PSO anymore. On the start screen, I can press A to get the main menu to pop up, but pressing A again does nothing. I can't use the analog sticks or D-pad to switch between different menu options, either -- all I can do is press X to go back to the "Press Enter Key" prompt. For some reason, pressing in the left analog stick functions exactly the same as A. Keyboard input works fine.

I've already set PsoBB.exe to run in compatibility mode for Windows XP Service Pack 2 and told it to run as administrator. I checked the controller settings in the Control Panel, and all the inputs seemed to be working. Also, I tested the controller with some other games that I used to use it with, and those still work. Any ideas why this is happening or what I can do to fix it?
 

Aleron Ives

Member
What are you using for your driver? At least under XP, you had to use a third-party driver to get the controller to work right, because Microsoft's driver wouldn't let you use the triggers as buttons, for one thing. I have to wonder if perhaps the default driver for Windows 10 is only using Xinput, while PSO uses DirectInput, so it isn't detecting the controller, or something like that.
 
I'm just using whatever driver Windows automatically installed. I don't think I ever installed any third-party drivers. Do you know where to find the one you were talking about?
 

Aleron Ives

Member
I wouldn't recommend trying to use an XP driver on Windows 10, even if you can still find it. I think it was called Cxbx, or something like that.
 

Sodaboy

Administrator
Staff member
I'm using Windows 10 with a 360 and a One controller... They both work without any extra effort on my part. Drivers seem to come from the OS or are at least downloaded the moment I plug in the device.

What I would suggest to you is to log in with your keyboard then go to gamepad settings and set them all to default and see if that solves it.
 
Tried that, but still nothing. =/ Both before and after setting it to default controls, the controller is entirely unresponsive after I've logged in. Unlike on the start screen where I can get it to do some very limited things, I can't even get the game to recognize its inputs enough to bind new controls. It's so bizarre to me that it almost works on the start screen, so it's obviously not completely dead. Also, I just noticed that when I'm logging in, I can move the shining thing around with the analog stick.
 

KillYourFM

Member
Bumping this. I just switched over from Ultima to here (you guys seem like you're doing things right) and am having the exact same problem. Literally identical. I can hit A at the menu screen but then it's unresponsive after that. Navigating via keyboard then resetting pad to default doesn't work. I'm also on Windows 10. Really the exact same issue. Hope someone can help :(
 
This might sounds stupid, but have you checked, that the X360 Controller is connected as Controller#1?

Because what you describe is exactly what a controller in port#2 would do (go to main-menu, but not more)
 

staphen

Member
Kuromori Yu pointed me in the right direction. Anyone still encountering this issue should check out devreorder.
https://github.com/briankendall/devreorder

As far as I can tell, this game enumerates DirectInput devices and uses the enumeration order to determine which port each controller is plugged into so you need to make sure the controller you want to use is at the top of the list. Just follow the instructions under the "Apply to single game or program" section of the README. By default, the game's .exe file is located in a folder under your home directory (C:\Users\YourUsername\EphineaPSO). As this is a 32-bit game, you will need to use the x86 version of the dinput8.dll file.
 
Last edited:

427Raven

Member
Tried this, worked the first time, but after that had constant issues. Ultimately decided to just go with the controller plugged into the computer directly via USB.
 
Top