HUD Skin causing crash on only non-admin user

Bliz

Member
I'm not sure if this problem is specific to Ephinea, so this may be the wrong place for it, but my friend is having a problem we could use some help with. I use a custom HUD skin that my friend likes, and they want to use it too, so we dropped the file in their /data folder as usual. They use Windows XP and usually run the game on their non-admin user account by selecting "run as administrator". The game now crashes when they do this, however the game and skin works fine if my friend logs into their admin account and runs it from there. I have no idea why adding a skin would make the game crash on one account but not the other, when the game skin-less works on both accounts. Is anyone familiar with this situation and knows a fix? My friend really wants to use the skin without having to switch user accounts every time they play the game.

(My friend uses singular they/them pronouns, sorry if that makes this post confusing to read.)
 

Aleron Ives

Member
It probably has to do with weird Windows file permissions bugs. You must run PSO as an administrator, and for whatever reason, BB is able to access data.gsl, but it can't access the external HUD file that isn't inside data.gsl, so it crashes. If he were on Windows 7, I would suggest that he try to take ownership of the BB data folder, but I don't know why XP would have that problem.
 

Andy

Toxicest player
Adding onto what Ives said, could you not just move the pso folder to desktop or somewhere that doesn't need admin rights to access?
 

Aleron Ives

Member
Well, that's what I'm saying. Maybe when he installed PSO everything in the default data folder got the right permissions, but when he copies the new skin file into the folder, it has different permissions from everything else, so he can't access it. The way to test would be to copy some other skin into the data folder to see if that skin also causes BB to crash.
 

Bliz

Member
Adding onto what Ives said, could you not just move the pso folder to desktop or somewhere that doesn't need admin rights to access?

This didn't work, but for some reason re-installing the game to the desktop did work. Thanks for the help everyone!
 
Top