Error 903


Hello and thank you in advance to whomever help me!

This has been my problem for a couple months now. Whenever I try to play this game, it shows me this error on the attached file below.

Already excluded the whole folder to my windows defender as well as ephinea.dll and still it persists.

But what's weird is whenever I try to open the launcher, it doesn't show the "User Account Control" pop-up. I've tested it on my other games, especially the PSU clementine ver. and it shows. I don't know if this is related to what is happening on my end or not but I'd like to entertain that phenomenon.

Windows 10 Ver 22H2 (everything is on the current updates)
Launcher v2.5.0


  • Screenshot 2023-12-08 222551.png
    Screenshot 2023-12-08 222551.png
    294.1 KB · Views: 9
Well...UAC being triggered usually says that the developer took shortcuts or wants permissions beyond what is reasonable (like a hyper aggressive anti-cheat.) A lot of older games have default installation folders that Windows 7/8/10/11 protect as well.

UAC not being triggered for Ephinea is generally what you want and not the cause of this problem.

903 is pretty on point in terms of error messages. You're not connecting to the patch server. Does the launcher error out as well, or can you see the news? Do you have any sort of strict firewall running?
It happens like this.

First it will tell the "client update failed" pop up

Then, when I press "OK" - One of the two things show up on the launcher shown below.

I don't think I have a strict firewall running, and I also add the the Ephinea launcher and PSOBB.exe to the allowed apps on windows firewall


  • Screenshot 2023-12-09 122026.png
    Screenshot 2023-12-09 122026.png
    122.1 KB · Views: 4
  • hunters online.png
    hunters online.png
    322.6 KB · Views: 4
  • no news.png
    no news.png
    226.2 KB · Views: 4
Well I only have one idea left

1. open command prompt (quick way: tap windows key, type cmd and hit enter)
2. in command prompt, type "tracert" without quotes then press Enter

(please) post results and hope ender-kun saves the day
I run into the exact same issue as well.
The error happens every time I launch the launcher, can happen before the news panel once the game started and before the character selection window.

I tried to deactivate my firewall (Windows Defender) - It didn't worked.
I did added Ephinea as an authorized app on the firewall - It didn't worked.

- Win 11 Home
- RTX 4080
- I9-13700K
- Ephinea Launcher v2.7.0
- Ephinea Server Client v1.510