Dreaded 903 Error

JezMM

Member
Friend of mine recently downloaded the game and is trying to play but keeps getting Error 903, failed to connect to patch server error every time she attempts to log in. She's running from online.exe as administrator with compatibility mode for Windows XP SP2, has disabled norton antivirus and even gone into it and manually added psobb.exe as an exception since it wasn't even listed as being blocked. The server was definitely up when she was attempting to login as I was playing myself.

Are there any other troubleshooting methods that tend to solve this that we've missed?
 

Neirene

Member
Tell her that it's most likely the firewall blocking her access to the server. Make sure to disable the antivirus completely as it might be controlling the firewall too!
 

CTB

JK hate paused, busy!
Check the router if she has one. Doubt it'll make a difference, but just in case: 11000, 11001, 12000 and 12001. Might as well try 6073 too. If TCP don't work, try UDP+TCP. If that doesn't work, try DMZ. And if that doesn't work, refer to PopCopy.

903 is annoying.
 

Sodaboy

Administrator
Staff member
DNS changed last night, though TTL on our host is only an hour, so it should have expired now.

I would try to do these things:

1. Reboot router
2. IPCONFIG /flushdns from an elevated command prompt.
3. Change her DNS servers on her router or PC to 8.8.8.8 and 8.8.4.4

If that doesn't work, it's either an ISP or Firewall issue (hardware or software).
 

tofuman

Administrator
Staff member
Try in command prompt:
nslookup ephinea1.pioneer2.net
and let us know what IP address it resolves.

Temporarily disable any firewall (also check your AV for a firewall) also any AV for testing.

PSOBB only uses TCP so enabling UDP on your firewall won't achieve anything. Adding your system to a DMZ on your router is definitely something I wouldn't recommend but if its just for testing I guess it would rule out any firewall issues on your router.
 
Non-authoritative answer:
Name: ephinea1.pioneer2.net
Address: 104.153.105.179

I think I did it right ;-; do you need the full thing that pops up?
 

Soly

Member
I just logged a while ago to check since I saw a different topic with the same issue, for me worked fine.

CTB said:
Check the router if she has one. Doubt it'll make a difference, but just in case: 11000, 11001, 12000 and 12001. Might as well try 6073 too. If TCP don't work, try UDP+TCP. If that doesn't work, try DMZ. And if that doesn't work, refer to PopCopy.
That's to actually host a server... it wont make any difference opening ports since your connection is going out, not coming in besides (I think) Ephinea doesn't run on those ports.
 

Sodaboy

Administrator
Staff member
I would check your firewall settings. Also try alternative DNS.

There isn't any reason you shouldn't be able to connect since you're hiting the webpage and its the same machine that hosts the patch and login server.

It's definitely going to come down to something on your machine or router blocking the connection.
 

Sodaboy

Administrator
Staff member
Don't really know how to help you there, buddy. Sorry!

You've checked Firewall, Antivirus, and I'm assuming you've reinstalled the game...

If you have another computer, I'd try it there. But, honestly, no idea what's going on with your connection to the server, especially since you can get to the website. Sounds like something is blocking your connection to the game, but it's not on our side.
 

Sick

Member
Sodaboy said:
Don't really know how to help you there, buddy. Sorry!

You've checked Firewall, Antivirus, and I'm assuming you've reinstalled the game...

If you have another computer, I'd try it there. But, honestly, no idea what's going on with your connection to the server, especially since you can get to the website. Sounds like something is blocking your connection to the game, but it's not on our side.

I was finally able to log on today. I had to use the CMD Prompt to flush cashes but, it eventually worked.
 
Top