Tethealla Server Setup Instructions

blooserv

Member
It's very sad ... we can't works on the new code ... I don't see any point of waiting a stable version before release on github , github was especialy made for dev version ... nvm , any ETA ?

Cordialy,
 

GunvoltEXE

Member
I keep getting "Your Client exe is too old."

Can someone please upload a client that works with this and points to 127.0.0.1?
 

legit nyck

Member
could you tell me how to create a link to my members can create the account on my server??
to be honest I do not remember how to do it thx
 

Soly

Member
You need a PHP (what I use, probably could use something else) website pretty much.
I could upload the PHP register I made later today.
 

Sodaboy

Administrator
Staff member
I put a whole sample registration website in a ZIP some time ago on here... lol. WHERE DID I PUT THAT THING?
 

Soly

Member
I recall having a PHP file on it... but on the latest download it's not :p
And it was said that it wasn't secure or something?
I assume it didn't have escaping, mysql stuff etc.

This one I put up I tried to make it something like that, added recaptcha too (but that's just a bit more involved)

Here is it, removed some files I call in with php... very basic but does the job, I think...
Move mysql and captcha files to somewhere else and put the correct paths in registration.php
 

Attachments

  • registration.7z
    2.7 KB · Views: 356
Last edited:

Soly

Member
Just open login_server.exe with a hex editor, type tethver and the first result should be something like tethver12510 ... change that to 12513 and it should be fine... otherwise you can download the login executable from my tools topic ... it includes both mysql and dat versions.. so just grab the appropriate one.
 

Muckbeast

Member
Just open login_server.exe with a hex editor, type tethver and the first result should be something like tethver12510 ... change that to 12513 and it should be fine... otherwise you can download the login executable from my tools topic ... it includes both mysql and dat versions.. so just grab the appropriate one.

I grabbed your file (for mysql version). Thanks!
 

zeta1

Member
Hello people, been a while :) I know you're all busy keeping this vibrant community alive but could we please have an updated (or more up to date) version of the server to download? A tonne of features and tweaks got added and I'd love to experiment with them without having to worry about getting banned or messing up my online character.
 

Peugeot

Member
Hi everybody,

I search to modify EXE for ip. Can you help me please?


Edit : in Hex edit, type

episode
and ramplace all 127.0.0.1 with your IP.
 
Last edited:

Shade53

Member
I'm having a similar issue as Peugeot, except I'm pretty sure I'm just inept at hex editing. I can get it edited so the clients can connect over LAN, but any clients I modify for WAN either don't run at all or they can't connect. I have all my ports forwarded for my server and the server computer is setup with a static IP, the bind IP is my server's LAN IP and the public IP I changed from 0 to my WAN IP in tethealla.ini, but still no use. I'm using HexEdit if that makes any difference.
 

Matt

Administrator
Staff member
When it comes to hex editing, never, ever, ever, ever, ever hit backspace or delete. You should only replace or the file size gets fucked and it won't run. If you need to delete, you replace with 00.
 

Shade53

Member
New issue, so completly editing my post to avoid double posting.
It seems my WAN users are having trouble connecting to the ship server and just the ship server. They keep getting error 100 and the login server is throwing me an error: "Client has closed the connection." Made sure ship ports are open, made sure ALL IP's were edited properly in exe and still same issue. But LAN is fine and even connecting to the xfinity hotspot here connects(tho I don't know if that still counts as LAN or not)
What could be going wrong?
 
Last edited:

SirGouki

Member
hotspots act as modem's and routers, so yes, if you're connecting to another computer or device behind the hotspot it counts as LAN, since LAN simple means Local Area Network, and it consists of everything on the same subnet, even across multiple routers. Since you are using Xfinity, I would contact them and ask if there is anything special they or you need to do to allow hosting, because I am aware they block that kind of stuff. Make sure your public ip address has not changed. If you are not paying for a static ip, which most people aren't, your ip will change once every 1-7 days. Since you mentioned hotspot, I can confirm that most providers for that kind of service will only sell static ips to a business account, and/or for well over $100 extra a month (VZW was $500 for personal/small business and ~$300 for larger corporations).
 
Top