Steam Controller!

I have an Xbox controller and it's great. But through a series of events I have found myself with 2 steam controllers. I want to use it simply because I can. So I guess this can be a place for me to share knowledge I get from working on a layout scheme or whatever. If you have any knowledge on the topic let me know!

Preferably I'd like to get this to run through the default online.exe (for the larger hud+ other options)

Thanks for dropping by!

2/15/16/ 3am: A preliminary test has shown me that steam things the game closes once online.exe is closed instead of jumping to psobb.exe not surprising. Using the launcher through psobb.exe doesn't register up/down arrow (via controller) perhaps it's related to xbox controller being plugged in?
 
Last edited:

anime

Bonsai Trees
Staff member
I've used one just fine by setting it up in big picture. Changed the settings for "Desktop Mode" and then just ran PSO without steam. Still not used to controllers though so I just use keyboard mostly
 

Char-E

The jobless android
I also have a Xbox controller and a Steam controller. Since the Xbox controller isn't configurable enough for me, I want to figure out what I can do with the Steam Controller.

Here's my first point of interest: If we add psobb.exe to the Steam Library then configure the Steam Controller for the game (in regular desktop mode, by right-clicking and finding the option from your library), can we launch online.exe like normal (without steam) and then have the Steam Controller settings for psobb.exe kick in when online.exe launches psobb.exe? Or does Steam have to be the program to launch psobb.exe for it's controller settings to kick in?

I'm going to test this and I'll edit this post with my findings.

*EDIT 1* Well, I was under the assumption that at least one of the options would work, but my controller isn't doing anything while psobb.exe is running. Not even the default desktop layout is responding. Has any of you had this problem?
 
Last edited:

Sodaboy

Administrator
Staff member
PSO doesn't support XINPUT controllers. Whatever controller you're using has to be using a DirectInput compatible driver. (Don't even know if the Steam controller has one.)
 

Xira

Member
To launch PSOBB with working Steam Overlay you must run Steam "as Administrator" (hold Shift, rightclick Steam, menu: Run as Administrator). Add online.exe as a "Non-Steam Game or Shortcut" (bottom left under games list). To make permanent: Right click Steam shortcut > Properties > Compatibility tab > Always Run as Admin. Not sure if this will cause issues with Steam.

Note: PSOBB will continue to react to your inputs even while you're in the overlay... typing to a friend and pressing W, for example, will cause your character to run forwards in the background.

Tested on Win10 x64 (UAC enabled). I previously thought Steam Overlay provided only XInput for Steam Controller but [UPDATE] it's working! I went into Big Picture Mode, selected the "Gamepad" preset for the game, loaded it up, and... it works! Sort of. BPM overlay seems to behave a little weird...

@Sodaboy My Xbox 360 controllers seem to control PSOBB just fine with no issues - haven't tried Xbox One - I'm assuming that both the Xbox 360 controller and Steam controller drivers are supporting DirectInput to some degree.
 
Last edited:

Char-E

The jobless android
To launch PSOBB with working Steam Overlay you must run Steam "as Administrator" (hold Shift, rightclick Steam, menu: Run as Administrator). Add online.exe as a "Non-Steam Game or Shortcut" (bottom left under games list). To make permanent: Right click Steam shortcut > Properties > Compatibility tab > Always Run as Admin. Not sure if this will cause issues with Steam.
Thanks for the tip about running as administrator. That got my Steam Controller working with the game.
 

Xira

Member
Update: So it works, but invoking the Big Picture Mode Steam Overlay from within PSO (at least in windowed mode, I haven't tested fullscreen) irrecoverably crashes the Overlay itself, and then the controller malfunctions.

For now, avoid accessing the BPM Overlay from within the game. You need the overlay running in the background for the controller to work - but avoid hitting SHIFT-TAB or the Steam Controller button. Your results may vary.

If you need to change the controller settings, ALT-TAB back to Big Picture Mode or close PSOBB and go back in. Hopefully this is a Steam problem and they'll fix it later.
 

anime

Bonsai Trees
Staff member
It might help that i've only played on keyboard and I dont use an xbox controller for anything.
I've heard switching from xbox controller to steam controller is VERY WEIRD

(or do you mean my config in particular? I thought it seemed pretty basic for a steam controller)
 

conenubi701

קרטל אל
The config in particular. I have it set for the Joystick to control the menus lol. I still hate the Steam controller because it feels too cheap in my hands, but the config I used for a few hours was pretty acceptable. I couldn't cut it with your config, I was trashhhhhhhh lmaooo.

It might help that i've only played on keyboard and I dont use an xbox controller for anything.
I've heard switching from xbox controller to steam controller is VERY WEIRD

(or do you mean my config in particular? I thought it seemed pretty basic for a steam controller)
 

Xira

Member
Bumping: I need to point out that it seems the Steam Overlay won't work unless ReShade's d3d8.dll is present in the PSOBB directory. Steam Overlay does not work with DirectX 8 games (and PSOBB is DirectX 8).

Revised quickguide to get Steam Controller working
  1. At minimum, if you don't have ReShade installed, put this d3d8.dll in your PSOBB folder next to online.exe https://github.com/crosire/d3d8to9/releases

  2. Quit / (shift-)Right-Click Steam -> Run as Administrator

  3. Add online.exe to Steam, name it "Phantasy Star Online Blue Burst" (the precise spelling of the name matters for saving/finding community profiles)

  4. Launch the game. By default the Steam Controller will be set up in an Xbox layout, which may not necessarily be the same as PSOBB's defaults. You may need to stop by F12 menu -> Options -> Pad Config to re bind your controls, but once you do that, your PSOBB will also be compatible with Xbox controllers.
[EDIT] I have solved the Administrator requirement
See my new super size guide with instructions for that
https://www.pioneer2.net/community/threads/the-super-steam-input-controller-guide.14974/
 
Last edited:
Top