[Solved] Launcher does not allow me to change most options

Discussion in 'Troubleshooting' started by PlatinumPSO, Jan 23, 2019.

  1. PlatinumPSO

    PlatinumPSO Member

    Hi, I'm new here. I am now playing this game offline, and deeply thankful for all the effort the folks around here have put into making that possible. So, first off: THANK YOU!
    Now, I've got it running as well as I can, and overall it is more than playable.

    Here's the issue keeping me, for the moment, from the full experience:

    When I run the launcher (I always choose "Run as administrator") it pops up, no prob.
    I click on Options and a separate box with resolution, windowed mode option, high res hud option, and Advanced options appears. I have windowed NOT checked, my native res is set (1920 x 1080), and high res hud is checked. So far so good.

    When I go to click on Advanced options I hit the bottleneck.

    Advanced options brings up a new window, with its own resolution pull-down widget, along with other choices. I can change all of the other choices, but there is nothing I can do with the resolution pull-down widget. It often is just filled with a blue color, and clicking on it "pulls-down" an empty field.

    As a result, I cannot save the settings within that particular window, as it keeps telling me I have not specified a resolution.

    I really really want to make the advanced graphics options on that second menu "stick" (far clipping pane in particular).

    I have seen some people talk about this but have yet to find an answer that works for my PC.
    My gaming laptop is:
    CUK ASUS ROG G751JL Full HD 17 Inch Gaming Laptop (Intel Core i7-4720HQ, 16 GB, 128GB SSD, 2TB HDD, Blu-Ray Drive, Black) with NVIDIA GTX 965M Windows 10 Gamer Notebook PC Computer

    I spent a week trying to solve this without bothering anyone, but I just can't seem to find an answer that works. I even reset my windows install and reinstalled everything. I'm on Win10 by the way.

    Any help would be very cool.
     
  2. PlatinumPSO

    PlatinumPSO Member

    Okay, after a lot of searching I learned (a) I'm not the only person with this issue and (b) some people had solved the issue, in a way.

    I still cannot use most of the options in the options launcher menu, but I no longer need to. Most of you are undoubtedly way more computer-savvy than I am, so this took me a while to piece together. In the end, everything in a computer is 0's and 1's, so I knew there had to be a way. I saw some other topics of folks with a similar dilemma. Sometimes they'd come back and post "all set now" but not how they solved it. One person - and I wish I bookmarked their thread, because they were awesome - hinted that they made some progress with the Registry Editor, but they appeared to hit a brick wall and a mod later posted a new option.exe that solved their issue, but it didn't solve mine.

    I went down the Registry Editor avenue.

    Tweaking settings via the Registry Editor solved my issue.

    If you go into your Windows folder (make sure "Show Hidden Items" is active in order to see everything) you will will find the Registry Editor, and inside that you will eventually find a SonicTeam folder and then the PSOBB folder. Inside PSOBB you will find multiple things that can be edited. The one to edit in order to change your graphic options is GRAPHICCTRL.

    After a bunch of fiddling this is what I finished with:
    0000 01 00 00 00 00 00 00 00 . . . . . . . .
    0008 00 00 01 00 00 01 00 00 . . . . . . . .
    0010 01 00 00 01 00 00 01 00 . . . . . . . .
    0018 00 01 00 00 00 00 00 00 . . . . . . . .
    0020 00 00 00 00

    What this does:
    Sets clipping to farthest possible distance. Without this I couldn't even see across the larger areas in Forest 1 and 2 - the background was open sky! With this you can see from the first area all the way to the waterfalls with no pop-up at all. The only pop-up is for items within the environment, but I think that's just the way the game is coded. The actual terrain is now all there, infinite view distance for all intents and purposes. Ditto monster and item distance - they are set as far as they can be set. For monsters it's great, because you can see them from far way, long before they con to you. Items don't spawn all that far away, but it is improved over the default state. After tinkering I left advanced shadows on the highest setting (so both your character and all other moving models in the game drop articulated shadows). They're rough by modern standards, but I think they are a net positive over the "blob" shadow. It turned off advanced effects. I actually think splashes looked better the old way. With advanced effects on, at least on my computer, it made lots of odd-looking black rings when you walk through water, which i hated.

    There is also a registry for saving the login name and password, which I activated with the Registry Editor. That one is simple.

    I'm leaving all this here to hopefully help future players who hit the wall I hit.

    Now that this is solved I am really enjoying PSO again. It's full widescreen, as you all know, with all the content, and now that I can max its settings, it's a joy to play.

    For me the last frontier is, if possible, to emulate the quick-select feature from GC PSO. I know you can hit ctrl-end, but that's hardly handy when playing with a controller. If I figure that one out, I'll post how here. If someone already knows how, hit me up with your knowledge.

    Thank you
    >Everyone
     

Share This Page