Resolved: Connection Issue

mooncow67

Member
Hey all,

I believe I have everything configured correctly. I was using my local IP (127.0.0.1) to play locally on my machine with no issues. I configured all the drops and experience rates as I wanted them and then attempted to make the server available on my local network for my roommates to play on with me.

My internal IP is 192.168.1.20. I've configured all IPs in ship.ini and tethaella.ini to point to here. Allowed ports 5278-5280,11000,11001,12000 and 12001 through my local firewall (allowed TCP and UPD both inbound and outbound) and forwarded them to my internal IP on our router. I also generated a new ship_key.dat and ship_key.bin using make_key.exe and placed the new ship_key.bin in the Ship Server folder.

I used Sodaboy's noob friendly .exe creator to create a TethVer12510 .exe with IP 127.0.0.1 and that worked fine to play on my local machine before I changed the IP.

I used Sodaboy's .exe creator again to create a TethVer12510 .exe with IP 192.168.1.20 and gave this to my roommate to try and connect. As well as use it on my local machine.

Now when I start up the server I see all the proper messages. Opening the proper ports and the ship server connecting with the login server.

When either of us try to connect we are able to connect to the patch server. I see it on the patch server window as well as seeing the proper message I configured on the game client. However, when we press enter to connect to the login server we get err903, no connection available and the server windows show no messages. Its like they're not even there.

Here's my tethaella.ini: http://pastebin.com/DqsgER7Y
Here's my ship.ini: http://pastebin.com/KzBTww9F

I am using the NoSQL version of the server. I've only logged into SQL servers and ended locked queries I am not very experienced with it.

Thank you for even reading this wall of text and I appreciate any help you can offer.


Resolution:
I got the SQL Version of the server all set up with the help of a friend. Learned a lot in the process which I am grateful for. Got the locally patched client set up, connected, everything worked great. Then we patched it for the local network, connected to the patch server and then nothing for the ship and login server. So I decided to take a look at the ini for the EXE patcher again. Turns out I am a major idiot and missed the IP for the ship and login server. Duh.

Well thank you anyway, sorry for any of you that wasted time reading.

And a huge thank you to everyone involved, the server and all your tools made this easy as pie.
 
Last edited:
Top