Malicious Website Warning

Mylandra

Member
I could not reply to the announce topic, so I've decided to make one here.

I can easily fix these issues flagging the website as malicious if you guys want to. The problem is that the psobb exes were never unpacked properly which raises shitload of antivirus warnings and issues with the game. I made a 1 minute change to the exe as a test that decreased the number of detection on VirusTotal from something like 19/55 to 2/55.

I haven't looked into the other 2 detections because I am unsure if people want this or not.

I wish I had the original exes tho lol
 

Sodaboy

Administrator
Staff member
Going to just reZIP them with a password and rename the archive. Hopefully that message will go bye-bye in 24 hours.

EDIT: Success!
 

tofuman

Administrator
Staff member
Being able to fix issues with the client would be worth doing anyway. If you could post the fixes it would be great.
 

Mylandra

Member
Sure, I don't think it's worth doing anything with the 1.25.10 version now anyway.
New Tethealla version is about to be released and should use the latest exe (Which has the same issues of being detected as a trojan horse, but much less than the 1.25.10 version apparently).

Is this the official version that will be used? http://www.pioneer2.net/downloads/TethExes12513.zip
I was thinking of maybe fixing other stuff like adding a simple ime patch while at it so that you can type both english/japanese/chinese with a single exe (Already have the fix somewhere if I can find it). Unicode is handled very poorly by the game, of course it could probably be worked out better so other languages like russian and arabic works if that matters.

Not sure if you had anything else in mind

Edit: Down to 1/55 on 1.25.13, leftover gameguard parts were apparently detected as a trojan horse by one AV lol
Exe loads much faster although it's not like anyone will notice unless he has some 15 years old computer.
 

tofuman

Administrator
Staff member
sounds good. I'm considering making the updated client 1.25.15. Purely so that it ensures that the client is running the correct EXE and will do as expected by the server.

But the memory offsets will be the same. Just things like Sega's locked items, Item Stacking, Menu titles and so on will be changed.
 
Top