External Clients Freezing at patch screen

Hello!

The server is working great for people within my LAN, even configured for my external IP (using loopback NAT)

However, people outside of my network are showing up on the patch server, and then freezing their clients.

AKA,

1. They press start game
2. I see an "Accepted PATCH connection from XXX,XXX,XXX,XXX:XXXXX"
3. They freeze.

However, when I connect locally, I will see a "Patch" connect, and then a "Data" connect


I am guessing this is some sort of router issue, but would appreciate any help/ideas!


Thanks again.
 
My Tethealla.ini......







# Tethealla Server version 0.001 Configuration File
#
# MySQL Host
localhost
# MySQL Username
XXXXXXXXXXXXXXXXXXXXXXX
# MySQL Password
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
# MySQL Database
pso_server
# MySQL Port
3306
# Server IP address to bind to (your private IP)
192.168.1.113
# Welcome message
Hello, and welcome to XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
# Server Port (This is the port the login server listens on... it will also open port+1 for the character server... You shouldn't need to change this.)
12000
# Max number of client connections
100
# Max number of ships
50
# Override IP (your public IP, leave 0 to just use the binded IP)
0
# Rare monster appearance rate (% is basically the number divided by 1000)
#
# Hildebear
7
# Rappies
8
# Lillies
8
# Slimes
7
# Merissa
7
# Pazuzu
7
# Dorphon Eclair
7
# Kondrieu
10000
# Global GM name color
1D94F7
# Local GM name color
B0CEDE
# Normal name color
FFFFFF
 
Top