Endlessly Updating Patch.dat

CrownG

Member
Hi, I've never had this issue on my other computer, though after moving and installing it on my spare PC the client continuously updates the patch.dat file, 1 day after i installed the game. I tried restarting, i tried uninstalling and reinstalling but it wont stop updating and refuses to let me on.

I've tried running Online.exe, PSOBB, and other files that can launch the game, normally and as admin but nothing works. My 2 friends have also been experiencing this, though I wasn't sure what was causing it and having experienced it myself I can't seem to find any general way of bypassing the constant request to update the patch.dat file. I've deleted the file, let it redownload it, still re-updates it. I've set compat mode to windows XP, no luck, turned on Run as Admin, no luck.

Any idea or advice to fix this?
 

Sodaboy

Administrator
Staff member
I'm not sure what patch.dat is... Are you talking about PsoBB.pat? Basically, you run online.exe as an admin and online.exe will overwrite PsoBB.exe with PsoBB.pat

If you're unable to do that, then online.exe doesn't have enough permission to overwrite PsoBB.exe and/or your antivirus could be blocking it's update too.

To manually get past this, rename the PsoBB.pat that it downloads to PsoBB.exe. It will download PsoBB.pat one more time, but then they should be identical when you relaunch and it should let you on.

But, all in all, this is a permission and possibly an antivirus issue. It always is.
 

CrownG

Member
Oops, yeah it's the Psobb.pat and I don't have any antivirus and got full Admin access, my friend does have an Anti-V and is on a passworded admin account.

Actually whenever i tried Launching "Online" it'd just say Failed to Patch or something similar. even if i ran as admin, So i'd just sign on using PsoBB.exe and it worked fine the first time.

I'm gonna reinstall, then run Online as Admin

EDIT:
After reinstalling BB, i immediately set "Online" to Run as admin, and windows XP SP3, then logged in to update, relaunched via desktop shortcut, updated version: 1.0.8 and now am at char select screen so all is good now.
 
Top