Can someone confirm if this is real?

Komishiro85

Member
http://strags.com/shpsobb/

Is a prank or joke? Also, is that the 1.25.13 installation? I really need that version and I honestly don't want to screw up my server folder and have to delete the files and paste a fresh list of server files back in the server folder.

I really have no idea if that is a sick prank or joke or if what happened to the guy was true or not.

Again, forgive me if this is not listed in the correct area. I really need the update and I've been working hard to find an easy way out. I'm not being lazy at all. I've actually been very busy for the last couple weeks with working on a some serious editing.

I really don't want to be a bother or anything. I apologize for posting a lot.
 

Komishiro85

Member
No, I've tried compiling. You don't know the trouble I went through trying to use Microsoft visual studio and will not go through that again lol. I did everything and added every file in the right place. I spent a couple hours trying to figure out what I did wrong and read in like every forum about it and it would not compile it.

This is the steps I took:

1. I installed Microsoft Visual Studio Express 2010 the C++ version.

2. I loaded up the project through Microsoft Visual Studio and went through each and every missing file and added them.

3. I tested the builder button, and it said 1 success.

4. I started the debug and it said I was either missing a file or there was not a pbd.

5. I read through as many forums as I could to fix my problem and double checked everything. I Checked debugger and all the file locations and made sure everything was at the right setting. I restarted my computer and the software and still no cigar.

6. I deleted all the server files and installed new ones and gave up on the update. It took way too long and will not compile. Heck, I had to watch a youtube video to see what compiling was.

Don't laugh :mad: I am not a scripter or programmer in any way. I do some script editing on pre existing scripts.
 

Soly

Member
1. I installed Microsoft Visual Studio Express 2010 the C++ version.
I think this was your first mistake, 2010 is way too old. Install 2015 Update 3 (it was released not long ago)
It will give you less problems, if you don't want 2015 then use 2013 but don't go lower than that.

Also the setup of the projects should be straight forward, you shouldn't require to add any files anywhere, just open the solution (.sln) and it will load, or it should.
After that, you probably have to fix a lot of inconsistencies like unsigned/signed >=< comparisons and stuff.
 

Komishiro85

Member
Ok, here's the thing. That update has nothing to do with anything. The original program used was 2008 edition to compile it. I knew someone would say something, but 2008 was used for this game. Just like people who use cheat engine. You don't need to upgrade your version if you don't want. It's all just light changes in the dash. Most of those codes were already executed years ago but they use the same code year after year.

Just like plugins (which we can't speak of) on emulators, you use the same versions that were used back in 2008 or 2009. Most of the plugins are just reused versions.
 

Soly

Member
I didn't say you would not be able to compile the servers with an older version, but as with everything, newer versions have improvements in several areas, like UI, functionality and security.

Sure, some programs or some specific updates are just changes in the dash, but I don't think this is the case with VS going from 2008 to 2015. (I have no idea what it has to do with emulators and plugins)

I was just giving you my opinion, anyway, you are free to use any version you want.
 
Top